PDA

View Full Version : "Ching Ching" Problem



ZMAN
08-23-2007, 02:39 PM
I am about to pull my hair out with this "ching ching / rattle" problem my 1987 IROC-Z has been having for over 10 years now. I have had multiple mechanics check the brakes, shock towers / suspension, front end and everywhere you could possibly look underneath the car. Yet, no one can find the problem. The car is stock overall. It does have wheel spacers for the after market wheels that are on it, but they wouldn't be able to move due to the lugs being tightened down on them. Could someone please give some divine insight?! Thank You.

Kevin

Purple 92 SS
08-24-2007, 01:22 AM
replace your tie rod end links with Energy suspension polyurathane parts. See if that fixes it. they're cheap enough like 15 bux a set. or something.

ZMAN
08-24-2007, 05:48 AM
:rolleyes: Thanks for replying Mr. President. I will try that. The "ching ching" sound sounds like a metal rod / shaft with a loose washer bouncing up and down on it. A few people said it was a loosened shock tower cap on top, just to give you a better idea of what this sounds like(the shocks were replaced). If what you mentioned doesn't resolve the problem, then do you have another prognosis? Thanks again and I will post a conclusion within a week.

ZMAN(Kevin)

2002Z4CSS
08-24-2007, 01:12 PM
Get a tool called chassis ears to help isolate the cause of the concern. :)

gorin002
09-17-2007, 12:59 PM
if it was windows mean software
i would try a regisrty cleaner or spyware cleaner
a car do not know

Purple 92 SS
09-18-2007, 03:41 AM
No problem kevin.

Personally from my experience with thirdgens, it is usually the tie rod ends that make that noise.. I can see where others would say shock / strut mount, but im pretty sure that the tie rod ends would be suspect in the thirdgens first if you ask me. Almost everytime we've had a car with that problem, its been those tie rod ends.. in fact, i cant recall a time when it wasnt the tie rod ends.